Сетевые решения — PPPoE

PPPoE – Point-to-Point Protocol over Ethernet, протокол передачи кадров PPP через Ethernet. Чаще всего используется с технологиями xDSL. Для реализации подключения по данному протоколу необходимо наличие xDSL линии связи, DSL модем и маршрутизатор Cisco.

Перед тем как приступить к настройке маршрутизатора, сначала необходимо подключить модем к линии связи, предоставленной провайдером, перевести модем в режим Bridge и задать значения VPI/VCI, выданные провайдером. Чаще всего используются значения VPI: 0, VCI: 35 или VPI: 8, VCI: 35.

После этого необходимо подключить один конец Ethernet кабеля к LAN порту в модеме, а другой — к WAN интерфейсу маршрутизатора.

Далее на маршрутизаторе необходимо создать логический интерфейс командой interface dialer 1. Чтобы автоматичеки получить IP адрес и DNS сервер от оператора связи, на интерфейсе нужно прописать команды ip address negotiated и ppp ipcp dns request. Командой encapsulation ppp определяем тип инкапсуляции.

Инкапсуляция происходит за счет добавления нового заголовка PPP размером 8 байт к Ethernet фрейму, величина которого по умолчанию равна 1500 байт. Поэтому чтобы избежать фрагментации, необходимо указать значение 1492 командой ip mtu 1492.

Обычно, сессия аутентификации протекает в двухстороннем порядке. Но в случае подключения к оператору связи по PPPoE от нас требуется только отправить ему имя пользователя и пароль. Для этого воспользуемся командой ppp authentication chap callin. Ее использование позволит маршрутизатору аутентифицировать удаленное устройство только в том случае, если удаленное устройство инициирует это подключение. Ни один нормальный провайдер, как правило, не станет открывать сессию аутентификации первым.

Укажем имя пользователя и пароль, любезно предоставленные оператором связи, командами ppp chap hostname YOURUSERNAME и ppp chap password YOURPASS и поставим метку на данном интерфейсе dialer pool 1.

Далее необходимо зайти в режим конфигурации WAN интерфейса на маршрутизаторе, допустим это будет интерфейс FastEthernet 4, командой interface fastethernet 4. Включим PPPoE — pppoe enable и укажем метку интерфейса Dialer 1 — pppoe-client dial-pool-number 1.

Чтобы завершить подключение по протоколу PPPoE, на внутреннем и внешнем интерфейсе (в нашем случае Dialer 1) необходимо настроить NAT и указать маршрут по умолчанию ip route 0.0.0.0 0.0.0.0 interface dialer 1.

Пример:

telecombook(config)#interface dialer 1
telecombook(config-if)#ip address negotiated
telecombook(config-if)#encapsulation ppp
telecombook(config-if)#dialer pool 1
telecombook(config-if)#ip mtu 1492
telecombook(config-if)#ip nat outside
telecombook(config-if)#ppp authentication chap callin
telecombook(config-if)#ppp chap hostname YOURUSERNAME
telecombook(config-if)#ppp chap password YOURPASS
telecombook(config-if)#ppp ipcp dns request

telecombook(config)#interface fastethernet 4
telecombook(config-if)#pppoe enable
telecombook(config-if)#pppoe-client dial-pool-number 1

telecombook(config)#interface vlan 1
telecombook(config-if)#ip address 192.168.1.254 255.255.255.0
telecombook(config-if)#ip nat inside
telecombook(config-if)#no shutdown

telecombook(config)#ip access-list extended NAT_TRAFFIC
telecombook(config-acl)#permit ip 192.168.1.0 0.0.0.255 any

telecombook(config)#ip nat inside source list NAT_TRAFFIC interface dialer 1 overload

telecombook(config)#ip route 0.0.0.0 0.0.0.0 interface dialer 1

В качестве дополнения к данному материалу, рекомендуется также прочитать статью NAT.

Понравилась статья? Поделиться с друзьями:
TelecomBook
Яндекс.Метрика