Сетевые решения — Подключение двух интернет провайдеров к маршрутизатору Cisco

К маршрутизатору Cisco можно подключить столько интернет провайдеров, сколько поддерживает отдельно взятый маршрутизатор виртуальных интерфейсов VLAN и/или подинтерфейсов типа GigabitEthernet0/0.100, GigabitEthernet0/0.101, GigabitEthernet0/0.102 и и.д. Я уже не говорю о физических WAN интерфейсах, на которых можно настроить подключение к провайдерам закрытыми глазами. Такая гибкость в настройках мне очень нравится и позволяет настроить оборудование практически под любые требования.

В приведенных ниже примерах отсутствуют маршруты по умолчанию. При желании узнать, как именно можно настроить маршруты и автоматическое переключение между двумя интернет-каналами, можно прочесть статью SLA.

1. Подключаемся через WAN порты

 Самый простой способ заведения нескольких провайдеров это, как было отмечено ранее, подключение их к WAN портам.

Закиньте с умом следующий конфиг в маршрутизатор и все заработает:

int Gi0/1
ip address x.y.z.q
ip nat outside

int Gi0/2
ip address x.y.z.w
ip nat outside

int Gi0/3
ip nat inside

ip access-list extended nat-traffic
10 permit ___
20 permit ___
30 permit ___
exit

route-map isp1 permit 10
match ip address nat-traffic
match interface GigabitEthernet0/1
exit

route-map isp2 permit 10
match ip address nat-traffic
match interface GigabitEthernet0/2
exit

ip nat inside source route-map isp1 interface GigabitEthernet0/1 overload
ip nat inside source route-map isp2 interface GigabitEthernet0/2 overload

2. Подключаемся через VLAN интерфейсы

 Можно подключиться к провайдерам используя виртуальные интерфейсы VLAN. Используется в том случае, если в маршрутизаторе всего один WAN интерфейс и несколько LAN интерфейсов. Правда нужно убедиться, что маршрутизатор поддерживает создание интерфейсов VLAN и в каком количестве.

Конфиг будет выглядеть так:

int Gi0/1
ip address x.y.z.q
ip nat outside

int Gi1/1
switchport mode access
switchport access vlan 100
spanning-tree portfast
no cdp enable

int vlan 100
ip address x.y.z.w
ip nat outside

int vlan 5
ip nat inside

ip access-list extended nat-traffic
10 permit ___
20 permit ___
30 permit ___
exit

route-map isp1 permit 10
match ip address nat-traffic
match interface GigabitEthernet0/1
exit

route-map isp2 permit 10
match ip address nat-traffic
match interface vlan 100
exit

ip nat inside source route-map isp1 interface GigabitEthernet0/1 overload
ip nat inside source route-map isp2 interface vlan 100 overload

3. Подключаемся через subinterface

Ну и наиболее универсальный способ подключения интернет провайдеров это использование subinterface. Многим знакомо выражение Router-on-a-stick.

Вот так это выглядит:

Конфиг будет соответственно следующий:

int Gi0/0.50
encapsulation dot1Q 50
ip address r.x.w.q
ip nat inside

int Gi0/0.100
encapsulation dot1Q 100
ip address z.x.y.q
ip nat outside

int Gi0/0.200
encapsulation dot1Q 200
ip address z.x.y.w
ip nat outside

ip access-list extended nat-traffic
10 permit ___
20 permit ___
30 permit ___
exit

route-map isp1 permit 10
match ip address nat-traffic
match interface GigabitEthernet0/0.100
exit

route-map isp2 permit 10
match ip address nat-traffic
match interface GigabitEthernet0/0.200
exit

ip nat inside source route-map isp1 interface GigabitEthernet0/0.100 overload
ip nat inside source route-map isp2 interface GigabitEthernet0/0.200 overload

Понравилась статья? Поделиться с друзьями:
TelecomBook
Яндекс.Метрика