Сетевые решения — Настройка Wi-Fi на Cisco 871 W-G-A-K9

В данной статье я хотел бы привести рабочие команды для настройки Wi-Fi на беспроводном маршрутизаторе Cisco 871W-G-A-K9.

Для начала я приведу конфиг, который предлагает Cisco, затем я продемонстрирую свой рабочий конфиг с некоторыми комментариями.

Итак, конфиг с сайта cisco.com:

! bridge irb ! interface Dot11Radio0 no ip address ! broadcast-key vlan 1 change 45 ! ! encryption vlan 1 mode ciphers tkip ! ssid cisco vlan 1 authentication open wpa-psk ascii 0 cisco123 authentication key-management wpa ! ssid ciscowep vlan 2 authentication open ! ssid ciscowpa vlan 3 authentication open ! speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0 rts threshold 2312 power local cck 50 power local ofdm 30 channel 2462 station-role root ! interface Dot11Radio0.1 description Cisco Open encapsulation dot1Q 1 native no cdp enable bridge-group 1 bridge-group 1 subscriber-loop-control bridge-group 1 spanning-disabled bridge-group 1 block-unknown-source no bridge-group 1 source-learning no bridge-group 1 unicast-flooding !
interface Dot11Radio0.2 encapsulation dot1Q 2 bridge-group 2 bridge-group 2 subscriber-loop-control bridge-group 2 spanning-disabled bridge-group 2 block-unknown-source no bridge-group 2 source-learning no bridge-group 2 unicast-flooding ! interface Dot11Radio0.3 encapsulation dot1Q 3 bridge-group 3 bridge-group 3 subscriber-loop-control bridge-group 3 spanning-disabled bridge-group 3 block-unknown-source no bridge-group 3 source-learning no bridge-group 3 unicast-flooding ! interface Vlan1 no ip address bridge-group 1 bridge-group 1 spanning-disabled ! interface Vlan2 no ip address bridge-group 2 bridge-group 2 spanning-disabled ! interface Vlan3 no ip address bridge-group 3 bridge-group 3 spanning-disabled ! interface BVI1 ip address 10.0.1.1 255.255.255.0 ! interface BVI2 ip address 10.0.2.1 255.255.255.0 ! interface BVI3 ip address 10.0.3.1 255.255.255.0 !

Оветы на вопросы по конкретным командам можно найти на сайте cisco.com, я же расскажу в общем, что делает эта конфигурация. В данном конфиге приведен пример создания трех беспроводных сетей: «cisco», «ciscowep» и «ciscowpa». Каждая из этих беспроводных стей принадлежит к своей сети VLAN, а именно 1, 2 и 3 соответственно. Сеть «cisco» — безопасная сеть с поддержакой WPA шифрования, остальные сети не поддерживают протоколов шифрования и их грубо можно приравнять к гостевым сетям.

BVI — Bridge Virtual Interface, интерфейс для взаимосвязи беспроводной сети с маршрутизатором и его соответствующими подсетями.

Далее, я приведу свой конфиг. В конфиге будет создана одна беспроводная защищенная сеть. Эта сеть будет принадлежать VLAN 1. На маршрутизаторе будет настроен DHCP сервер, который будет выдавать адреса как беспроводным клиентам, так и проводным, подключенным непосредственно к маршрутизатору.

Команды, относящиеся к DHCP серверу:

ip dhcp pool sdm-pool
   import all
   network 10.10.10.0 255.255.255.248
   default-router 10.10.10.1
   lease 0 2

ip dhcp excluded-address 10.10.10.1

Команды, относящиеся непосредственно к настройкам беспроводного интерфейса:

interface Dot11Radio0 no ip address ! encryption vlan 1 mode ciphers aes-ccm ! ssid telecombook ! speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0 station-role root!interface Dot11Radio0.1 encapsulation dot1Q 1 native no cdp enable bridge-group 1 bridge-group 1 subscriber-loop-control bridge-group 1 spanning-disabled bridge-group 1 block-unknown-source no bridge-group 1 source-learning no bridge-group 1 unicast-flooding
!

Обратите внимание на настройки основного интерфейса и сабинтерфейса.

Теперь настроим параметры беспроводного подключения:

dot11 ssid telecombook
   vlan 1
   authentication open
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 0 telecombook123

Далее привяжем интерфейс Vlan1 к бриджу:

interface Vlan1
 no ip address
 ip tcp adjust-mss 1452
 bridge-group 1
 bridge-group 1 spanning-disabled

Затем создадим BVI интерфейс:

bridge irb

interface BVI1
 ip address 10.10.10.1 255.255.255.248

Если бы мы привязали адрес 10.10.10.1/29 к интерфейсу Vlan1, тогда беспроводные клиенты не смогли бы получить IP адрес по DHCP. Поэтому, если у вас уже имеется IP адрес на интерфейсе Vlan1 и вы попытаетесь использовать этот же, либо любой другой адрес из этой же подсети на BVI, то маршрутизатор сообщит об ошибке: «% 10.10.10.0 overlaps with Vlan1». Чтобы использовать адрес интерфейса Vlan на BVI, его необходимо предварительно удалить командой no ip address и перенести на BVI интерфейс. Тем самым мы обеспечим шлюзом по умолчанию как проводных, так и беспроводных пользователей.

Далее приведена выдержка из рабочей конфигурации по настройке беспроводной сети на беспроводном маршрутизаторе Cisco 871, суммирующая все вышесказанное:

telecombook#sh run
!
dot11 ssid telecombook
   vlan 1
   authentication open
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 0 telecombook123
!
bridge irb
!
interface Dot11Radio0
 no ip address
 !
 encryption vlan 1 mode ciphers aes-ccm
 !
 ssid telecombook
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
 54.0
 station-role root
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no cdp enable
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Vlan1
 no ip address
 ip tcp adjust-mss 1452
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address 10.10.10.1 255.255.255.248

Понравилась статья? Поделиться с друзьями:
TelecomBook
Яндекс.Метрика