Установка и первоначальная настройка IP телефонов Cisco

Автор: privilege15 от . в разделе Коммутация и маршрутизация

Cisco IP Phone 7942GШаг 1. Питание

Прежде чем приступать к настройке IP телефона Cisco, его необходимо подключить к сети передачи данных и подать питание. Подробнее о питании телефонов описано в статье Питание IP телефонов.

Шаг 2. Настройка порта коммутатора

Когда первый шаг будет позади необходимо настроить порт коммутатора, к которому подключен телефон, а именно поместить порт в голосовой VLAN. Телефоны подключаются по следующей схеме:

ip phone

Команды для настройки коммутационного порта:

Switch#conf t
Switch(config)#vlan 10
Switch(config-vlan)#name DATA
Switch(config-vlan)#exit
Switch(config)#vlan 45
Switch(config-vlan)#name VOICE
Switch(config-vlan)#exit
Switch(config)#interface Gi0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#switchport voice vlan 45
Switch(config-if)#spanning-tree portfast

Шаг 3. Настройка DHCP

Для нормального функционирования IP телефона, ему необходимо выдать IP адрес. Кроме IP адреса обязательным параметром является опция 150, в которой задается IP адрес сервера обработки вызовов, в нашем случае Cisco Unified Communications Manager Express (CME).

Настройка DHCP для Voice VLAN на маршрутизаторе Cisco:

CME_Router(config)#ip dhcp pool VOICE
CME_Router(dhcp-config)#network 10.1.1.0 255.255.255.0
CME_Router(dhcp-config)#default-router 10.1.1.1
CME_Router(dhcp-config)#option 150 10.1.1.1
CME_Router(dhcp-config)#dns-server 4.2.2.2

Шаг 4. Настройка TFTP сервера

С TFTP сервера телефоны забирают свою прошивку (программное обеспечение) при загрузке. В роли TFTP сервера может выступать любое устройство, поддерживающее данный функционал, но обычно эту роль выполняет либо маршрутизатор CME, либо сервер CUCM Publisher (о нем расскажу в другое время).

Телефоны забирают с TFTP сервера:

  • Программное обеспечение;
  • Конфигурационный файл.

Маршрутизатор создает и модифицирует конфигурационные файлы во время своей первичной и всех последующих настроек соответственно. Так, изменив название прошивки телефона, изменения будут автоматически внесены в конфигурационный файл. При следующей загрузке, IP телефон получит конфигурационный файл, увидит, что текущая прошивка устарела, подключится к TFTP серверу и загрузит новую.

Если индивидуальная конфигурация телефона не была задана, тогда он получит при первой загрузке конфигурационный файл по умолчанию – XMLDefault.cnf.xml. Этот файл содержит IP адрес, номер порта, который используется для подключения к серверу обработки вызовов (CME), названия файлов с программным обеспечением для каждой модели телефона.

Конфигурационные файлы разделяют на два типа:

  • Индивидуальные для каждого телефона;
  • Общие для определенной модели телефонов.

Индивидуальный конфигурационный файл в своем названии содержит мак-адрес телефона, для которого он предназначен. Дополнительные общие конфигурационные файлы могут создаваться, например, для управления тональными сигналами и рингтонами, для изменения расположения кнопок на дисплее телефонов и пр.

Программное обеспечение для каждого IP телефона состоит из нескольких файлов, например, ПО для телефонов 7940/7960 состоит из четырех файлов:

CME_Router# dir flash:/phone/7940-7960
Directory of flash:/phone/7940-7960/
98	-rw-	129824 	May 12 2008 21:33:56 -07:00	P00308000500.bin
99 	-rw- 	458 		May 12 2008 21:33:56 -07:00	P00308000500.loads
100	-rw- 	705536 	May 12 2008 21:34:00 -07:00	P00308000500.sb2
101 	-rw-	130228 	May 12 2008 21:34:00 -07:00	P00308000500.sbn

129996800 bytes total (28583936 bytes free)

Размер ПО для «тяжелых» телефонов Cisco может достигать 40 мегабайт, поэтому его целесообразно хранить на внешнем TFTP сервере, указав его адрес в режиме конфигурации telephony service командой cnf-file location tftp://<ip адрес>.

Если в роли TFTP сервера выступает маршрутизатор CME, тогда необходимо разрешить для скачивания хранящиеся в нем файлы образов прошивок телефонов:

CME_Router# dir flash:/phone/7940-7960
Directory of flash:/phone/7940-7960/
98	-rw- 	129824 	May 12 2008 21:33:56 -07:00 P00308000500.bin
99 	-rw- 	458 		May 12 2008 21:33:56 -07:00 P00308000500.loads
100 	-rw-	 705536	May 12 2008 21:34:00 -07:00 P00308000500.sb2
101 	-rw- 	130228		May 12 2008 21:34:00 -07:00 P00308000500.sbn
129996800 bytes total (28583936 bytes free)

CME_Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
CME_Router(config)# tftp-server flash:/phone/7940-7960/P00308000500.bin alias P00308000500.bin
CME_Router(config)# tftp-server flash:/phone/7940-7960/P00308000500.loads alias P00308000500.loads
CME_Router(config)# tftp-server flash:/phone/7940-7960/P00308000500.sb2 alias P00308000500.sb2
CME_Router(config)# tftp-server flash:/phone/7940-7960/P00308000500.sbn alias P00308000500.sbn

Для других моделей IP телефонов Cisco необходимо по аналогии повторить процесс. Перед тем как приступить к настройке телефонов, необходимо задать основные первоначальные параметры, относящиеся ко всем телефонам, в режиме telephony service.

Шаг 5. Настройка Telephony Service

Далее приведен минимальный набор параметров, необходимых для запуска службы телефонии в целом на маршрутизаторе CME:

  • IP адрес источника;
  • Max-DN;
  • Max-Ephones.

Соответствующие команды:

CME_Router(config)# telephony-service
CME_Router(config-telephony)# ip source-address 10.1.1.1
CME_Router(config-telephony)# max-ephones ?
    Maximum phones to support
CME_Router(config-telephony)# max-ephones 24
CME_Router(config-telephony)# max-dn ?
    Maximum directory numbers supported
CME_Router(config-telephony)# max-dn 48

Команда max-ephones задает максимальное количество IP телефонов, которые будут поддерживаться маршрутизатором. Командой max-dn указывается максимальное количество объектов внутренней адресации телефонов. Команда ip source-address показывает, какой IP адрес маршрутизатор будет использовать для обработки запросов на регистрацию IP телефонов.

!

Параметры max-ephones и max-dn оказывают непосредственное влияние на то, сколько памяти зарезервирует маршрутизатор для CME сервиса. Установка большего значения, чем это необходимо, зарезервирует избыточные ресурсы маршрутизатора, что отразится на других сетевых сервисах. Более того, значение параметра max-ephone не должно быть больше количества купленных CME лицензий.

Шаг 6. Настройка Ephone-DN

Ephone-dn, в простейшем понимании, определяет номер, который может быть назначен одной или нескольким клавишам одного или нескольких IP телефонов. Ephone-dn функционирует в одном из трех режимов:

  • Single-line ephone-dn. В данном режиме, ephone-dn может обработать только один вызов в отдельный промежуток времени. Если линия ephone-dn уже занята текущим вызовом, тогда любой другой вызов с использованием данного ephone-dn приведет к сигналу «занято».
  • Dual-line ephone-dn. Данный режим позволяет обработать одновременно два вызова. Одновременно с этим, появляется возможность использовать такие функции как ожидание вызова, конференц-связь, переводы звонков, для использования которых требуется две линии.
  • Octo-line ephone-dn. Режим множественных линий, который появился в новых версиях IOS и который чаще всего используется на ресепшине. Данный режим потребляет очень много ресурсов маршрутизатора, поэтому его использование необходимо тщательно спланировать.

В корпоративной среде обычно используется режим dual-line.

Пример настройки single-line и dual-line ephone-dn:

CME_Router# conf t
Enter configuration commands, one per line. End with CNTL/Z.
CME_Router(config)# ephone-dn ?
	ephone-dn tag
CME_Router(config)# ephone-dn 1
CME_Router(config-ephone-dn)# number ?
    WORD	A sequence of digits - representing telephone number
CME_Router(config-ephone-dn)# number 1000
CME_Router(config-ephone-dn)# exit
CME_Router(config)# ephone-dn 2 ?
    dual-line	dual-line DN (2 calls per line/button)
    <cr>
CME_Router(config)# ephone-dn 2 dual-line
CME_Router(config-ephone-dn)# number 1001

Тэг для ephone-dn может быть любым. В нашем случае любым уникальным от 1 до 150.

Одному ephone-dn можно присвоить более одного номера, так, например, если один из них используется для звонков внутри сети, а второй для приема входящих вызовов из ТСОП, используя Direct Inward Dial (DID) номер, он же прямой входящий набор номера,  применяется следующий синтаксис:

CME_Router(config)#ephone-dn 2 dual-line
CME_Router(config-ephone-dn)#number 1001 secondary 1234561001
!

DID– это функция, поддерживаемая операторами телефонной связи, с которыми необходимо заключить договор, которая позволяет позвонить на внутренний номер абонента напрямую минуя промежуточную стадию, например, донабор номера сотрудника или секретаря.

Шаг 7. Настройка Ephone

Настройка каждого ephone в маршрутизаторе отражает настройку одного реального IP телефона или SoftPhone. Параметр max-ephone в разделе конфигурации telephony service задает максимальное количество ephone инстансов, которые можно создать и которыми можно управлять:

CME_Router(config)# ephone ?
    	Ethernet phone tag
CME_Router(config)# ephone 1
CME_Router(config-ephone)#

После создания ephone, необходимо осуществить логическую привязку физического телефона к созданному ephone 1. Привязка телефона выполняется с помощью его MAC-адреса. MAC-адрес телефона можно найти:

  • На коробке с IP телефоном Cisco;
  • На самом телефоне Cisco;
  • В меню Settings телефона Cisco.

Узнав MAC-адрес можно осуществить привязку IP телефона к определенному ephone с помощью следующих команд:

CME_Router(config)# ephone 1
CME_Router(config-ephone)# mac-address ?
    H.H.H Mac address
    <cr>
CME_Router(config-ephone)# mac-address 000e.083b.b1cf

Для проверки правильности настроек можно воспользоваться командой show ephone.

CME_Router# show ephone
ephone-1 Mac:0014.1C48.E6D1 TCP socket:[2] activeLine:0 REGISTERED in SCCP ver 11
and Server in ver 8
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
IP:10.5.40.31 52777 Telecaster 7960 keepalive 0 max_line 6

ephone-2 Mac:000C.2957.ACF5 TCP socket:[-1] activeLine:0 UNREGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:0
IP:0.0.0.0 0 Unknown 0 keepalive 0 max_line 0

Вывод команды show ephone показывает два телефона, один из которых зарегистрирован на сервере CME, а другой нет.

Шаг 8. Привязка ephone к ephone-dn

После того как физический IP телефон был привязан к его цифровой сущности ephone, необходимо связать ephone с соответствующей номерной базой ephone-dn.

Синтаксис: button <физическая кнопка><разделитель><ephone-dn>.

CME_Router(config)# ephone 1
CME_Router(config-ephone)# button 1:2
CME_Router(config-ephone)# restart

Команда button 1:2 назначает ephone-dn 2 на кнопку 1 виртуального телефона ephone 1, который связан с физическим аппаратом. Разделитель “:” означает, что это обычный звонок, который заставит этот телефон зазвонить если набрать номер 1001 (номер ephone-dn). Команда restart мягко перезагружает телефон, чтобы он подгрузил новую конфигурацию с TFTP сервера.

Используя указаный синтаксис можно назначить оставшимся кнопкам другие номера, например:

CME_Router(config)# ephone 1
CME_Router(config-ephone)# button 1:2
CME_Router(config-ephone)# button 2:1

Или одной строкой:

CME_Router(config)# ephone 1
CME_Router(config-ephone)# button 1:2 2:1

Проверить настройки телефона можно с помощью команды show ephone.

CME_Router# show ephone
ephone-1 Mac:0014.6A16.C2DA TCP socket:[5] activeLine:0 REGISTERED in SCCP ver 8
and Server in ver 8
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:7
IP:10.5.40.32 14719 7912 keepalive 2701 max_line 2 dual-line
button 1: dn 2		number	1001	CH1 IDLE 	CH2 IDLE
button 2: dn 1		number	1000	CH1 IDLE

Стоит обратить внимание на первую клавишу, где используются два канала связи, в то время как вторая клавиша имеет лишь один.

В заключение, приведу список всех упомянутых в статье команд для реализации сценария установки трех IP телефонов Cisco:

Порт, куда подключается телефон:

Switch#conf t
Switch(config)#vlan 10
Switch(config-vlan)#name DATA
Switch(config-vlan)#exit
Switch(config)#vlan 45
Switch(config-vlan)#name VOICE
Switch(config-vlan)#exit
Switch(config)#interface Gi0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#switchport voice vlan 45
Switch(config-if)#spanning-tree portfast

DHCP:

CME_Router(config)#ip dhcp pool VOICE
CME_Router(dhcp-config)#network 10.1.1.0 255.255.255.0
CME_Router(dhcp-config)#default-router 10.1.1.1
CME_Router(dhcp-config)#option 150 10.1.1.1
CME_Router(dhcp-config)#dns-server 4.2.2.2

TFTP:

CME_Router# dir flash:/phone/7940-7960
Directory of flash:/phone/7940-7960/
98	-rw- 	129824 	May 12 2008 21:33:56 -07:00 P00308000500.bin
99 	-rw- 	458 		May 12 2008 21:33:56 -07:00 P00308000500.loads
100 	-rw-	 705536	May 12 2008 21:34:00 -07:00 P00308000500.sb2
101 	-rw- 	130228		May 12 2008 21:34:00 -07:00 P00308000500.sbn
129996800 bytes total (28583936 bytes free)

CME_Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
CME_Router(config)# tftp-server flash:/phone/7940-7960/P00308000500.bin alias P00308000500.bin
CME_Router(config)# tftp-server flash:/phone/7940-7960/P00308000500.loads alias P00308000500.loads
CME_Router(config)# tftp-server flash:/phone/7940-7960/P00308000500.sb2 alias P00308000500.sb2
CME_Router(config)# tftp-server flash:/phone/7940-7960/P00308000500.sbn alias P00308000500.sbn

Общие настройки CME:

CME_Router(config)# telephony-service
CME_Router(config-telephony)# ip source-address 10.1.1.1
CME_Router(config-telephony)# max-ephones 3
CME_Router(config-telephony)# max-dn 5

Внутренняя адресация телефонов:

CME_Voice(config)# ephone-dn 10 dual-line
CME_Voice(config-ephone-dn)# number 1010
CME_Voice(config)# ephone-dn 11 dual-line
CME_Voice(config-ephone-dn)# number 1011
CME_Voice(config)# ephone-dn 12 dual-line
CME_Voice(config-ephone-dn)# number 1012
CME_Voice(config)# ephone-dn 13 dual-line
CME_Voice(config-ephone-dn)# number 1013
CME_Voice(config)# ephone-dn 15 dual-line
CME_Voice(config-ephone-dn)# number 1015

Привязка физических телефонов к виртуальному отражению с последующей адресацией:

CME_Voice(config)# ephone 7
CME_Voice(config-ephone)# mac-address 0023.331a.90e5
CME_Voice(config-ephone)# button 1:10 2:15
CME_Voice(config-ephone)# exit
CME_Voice(config)# ephone 8
CME_Voice(config-ephone)# mac-address 0024.9736.1a10
CME_Voice(config-ephone)# button 1:11 2:15
CME_Voice(config-ephone)# exit
CME_Voice(config)# ephone 9
CME_Voice(config-ephone)# mac-address 0023.331a.90e0
CME_Voice(config-ephone)# button 1:12
CME_Voice(config-ephone)# button 2:13
CME_Voice(config-ephone)# button 3:15
CME_Voice(config-ephone)# exit

Сервисы